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CAD Data checking for Quality Assurance Guide 

 

Introduction 

Quality assurance is a way of preventing mistakes and avoiding problems when delivering a 

product to customers. In this case, the product is an InRoads digital terrain model of a proposed 

construction project. The procedures below are designed to familiarize the designer with the data 

that is received at each stage of the design process, identify potential issues with the data, locate 

areas of special concern within the project limits, and review produced data prior to its being 

handed off to the next phase of design. The idea being to eliminate, as much as possible, passing 

on errors or design flaws from one stage of the project to the next. 

Quality assurance is especially important when project deliverables are electronic data files, such 

as ALG (geometry), DTM (terrain models), DGN/DWG (CADD drawings), and/or LandXML 

(geometry, terrain model, or cross section data translated to LandXML format). In the event that a 

project is a candidate for 3D engineered modelling for highway construction, it is imperative that 

they represent the intended design accurately because they can be used for Automated Machine 

Grading (AMG). The result of following these quality assurance procedures along with the 

Specifications DB 2016-4 (refer to PDM 8-33 to 36)  is a 3D engineered model for construction that 

is ready for use on the construction site. 

Note: The creation of LandXML files is covered in Workflow IR 17 – Exporting A LandXML File 

Outline for InRoads Quality Assurance 

1. Initial Data Review - The initial evaluation process is used to determine how a project will 

be designed.  It is also used as a final check of the existing ground surface to ensure that 

there are no busts in the data and to identify areas of special concern.  The following items 

are used for the initial surface review: 

a. Review existing surface Properties 

b. Review existing surface Topo 

c. Review existing surface Contours 

d. Review existing cross sections 

2. Setting Design Parameters and Reviewing Design Data – This includes various settings 

that control where design data is generated and how data is displayed in MicroStation.  

Each task in creating design data should be reviewed as it is completed so that the next task 

will start with the most accurate data possible. 

a. Geometry Review 

i. Review Horizontal Geometry 

1. Enter Event Points for areas of special concern. 

ii. Reviewing Vertical Geometry 

1. Profile Exaggeration 

2. Annotating Profiles 

  

https://www.codot.gov/business/designsupport/bulletins_manuals/design-bulletins/db-2016-4/view
https://www.codot.gov/business/designsupport/cadd/cadd-workflows/v8i-ss2/ir-17/view
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b. Roadway Designer Set up and Review 

i. Template Drop Interval 

ii. Changing Templates  

iii. Using Event Points and other important stations 

a. Horizontal and Vertical Cardinal Points (PC, PT,PVC,PVT, etc.) 

b. Drainage structure crossings 

c. Driveways  

d. Median crossovers 

e. Intersections 

f. Pavement changes 

g. Inlets and manholes 

Note: Important locations could be stored as “Key Stations” within the 

*.ird file in Roadway Designer. However, storing them as “Event 

Points” within the *.alg file makes them available to team members 

without having to load the *.ird file. 

iv. Setting up and reading Roadway Designer displays 

v. Review Component Quantities 

3. Creating and Reviewing the Design Surface Model -  

a. Set up the Create Surface command 

b. Review design surface Properties 

c. Review design surface Contours 

d. Review design surface Topo 

4. Comparing Existing Surface and Design Models Data – Design data should be 

compared to the existing surface data and design criteria at the completion of each design 

step to ensure that the most efficient design is being developed. 

a. Cross Section set-up 

b. End Area Volume set-up 

c. Generating Triangle Volumes 

d. Comparing Triangle Volumes to End Area Volumes 

e. Using Mass-Haul Diagrams 
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1. Initial Data Review  

The designer should review the existing ground dtm upon receipt. This is so that the designer can 

become acquainted with the terrain and to verify that there are no errors in the surface. This review 

should include reviewing the Surface Properties and reviewing contours of the surface. 

a. Surface Properties 

The Surface Properties dialog box contains general information about the selected surface such 

as the surface type, number and type of features within the surface, data ranges, etc.  To review 

the Surface Properties: 

1. Right click on the surface name in the InRoads Explorer and select Properties from the list. 

 

 

2. In the Surface Properties dialog box, review the Data Range area. Look for entries that 

seem abnormal for the area of the project. The most common and easily recognizable issue 

is a zero minimum elevation. 
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Just because there is elevation data at zero does not necessarily mean a bust in the survey. 

Untriangulated data stored in the surface at a zero elevation will not affect the triangles above. 

However, seeing a zero elevation should prompt additional investigation to determine if the data 

is valid or not. 

1. Left click on the Advanced tab. The Cross Sections and Profiles Symbology should be set to 

T_Existing_Ground. This symbology causes the existing ground to be displayed as a green 

dashed line (the CDOT standard) in cross sections and profiles. If the symbology is set 

incorrectly, inform the surveyor so that it can be reset.  

 

2. Left click Close to dismiss the dialog box. 
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b. Review existing surface Topo 

A MicroStation file of the surveyed topo can be found in the \ROW_Survey\Drawings\ 

Reference_Files folder under the project directory in ProjectWise. The illustration below shows 

the path to the survey topo file in a sample project. 

 

There may be several versions of the topo file in this folder. Because of the way that data is 

written from the fieldbook, a version is created for each plan sheet scale. 

Open the JPC#SURV_Topo_Scale##.dgn file read only so that no inadvertent changes are 

made. Looking at the topo, items like right of way, utilities, drainage structures, and driveways 

can be identified. Review the data with an eye towards items that can and/or will influence the 

design such as existing pavement widths, Drainage structure and utility crossings, right of way, 

buildings, guardrail, pedestrial paths, environmental sites, signage, and other structures near 

the proposed roadway, etc. 
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Generally, survey data is collected in a narrow corridor along the path of proposed construction. 

However, having a larger view of the area surrounding the construction site can be beneficial. 

This can be obtained through the use of aerial photographs. The top illustration below shows 

the surveyed data of a project. The bottom illustration shows the same data overlaid onto an 

aerial photo. 

 

 

 

Survey data only 

Survey data overlaid on aerial photo 
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As can be seen in the two illustrations, items of interest show up in the photo that are not 

represented in the survey data. CDOT has an archive of aerial photographs that cover the entire 

state. Refer to the workflow Workflow MS 12 - Accessing Imagery Files to access and copy 

photos from the archive to the project folder. 

 

Rotating the view in MicroStation can also show large elevation differences in surface data. 

3. Using the View Controls, select Rotate View > Front View (or Right View) 

 

4. Select Fit View. This fits all the data within the file into the view. The rotation shows the Z 

axis (elevation) from top to bottom. The illustration below shows data with a large 

variance in elevation. 

 

Remember to rotate the view back to the Top View when the review is completed. 

  

https://www.codot.gov/business/designsupport/cadd/cadd-workflows/v8i-ss2/ms-12/view
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c. Reviewing Contours 

Reviewing contours of the existing surface will readily show if zero elevation data in the surface 

is affecting the triangulated model. It can also indicate other anomalies that are not apparent in 

the surface properties. Surface anomalies will generally appear as a group of densely packed 

concentric contours. 

  

To display contours of the existing ground surface: 

1. From the InRoads menu bar, select Surface > View Surface > Contours. This displays the 

View Contours dialog box. 
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2. In the View Contours dialog box, left click the Preferences button. This displays the 

Preferences dialog box. Preferences are used to determine how the contours are displayed 

in MicroStation. 

 

3. Highlight the desired preference from the list then left click the Load button followed by the 

Close button. 
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Using a small interval makes surface anomalies show up better, though it will increase 

processing time. The illustrations below show the same area of a surface that contains a shot 

with a 5 foot elevation bust. The major intervals used are (from left to right); 1’, 10’, 100’. Notice 

how much easier the anomaly is to see in the left illustration.  

 

 

 

Any questions regarding the existing ground surface should be referred to the surveyor 

responsible for the data. 

d. Creating Cross Sections 

Reviewing cross sections of the existing surface is another way to verify the data. They can 

also be used to determine various aspects of the surface, such as the side slope value on 

existing roads.  

1. Select Evaluation > Cross Section > Cross Sections from the InRoads bar menu. 

This displays the Cross Sections dialog box. 

2. From the Cross Sections dialog box, left click the Preferences button. This displays 

the Preferences dialog box that is associated with Cross Sections. 

3. From the Preferences dialog box, highlight the desired preference and left click 

Load. Because these cross sections are for review only it is suggested to use the 

Stacked 20 per column preference. 

  

1 foot contour            10 foot contour            100 foot contour 
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4. Left click Close to dismiss the Preferences dialog box. 

 

5. Set the Interval to the desired value. 10 is the standard template drop interval and 

can be used for this review. 

6. Set the Left Offset and Right Offset values to ensure that the entire width of the 

design area is visible within the cross section window. 
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7. Select the Source leaf and verify that the correct alignment is selected. 

 

8. Expand the Controls folder. Set the Limits as needed. 

 

9. Left click the Apply button then left click the location for the cross sections. This 

creates a cross section set. Below is an example of what a cross section will look like.  
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To review existing sideslope data, annotate the segments of the existing surface. 

10. From the Cross Sections dialog box, select the Annotate Cross Section leaf. 

 

11. Toggle off Include Points and Include Features. 
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12. Toggle on Include Segments. 

13. Toggle on Minimum Annotation Width and set the value to 5. 

14. Toggle on Slope Tolerance and set the value to 1.00%. 

 

These options allow for an adequate amount of annotation and keep the plans readable. If 

more annotation is required, adjust the values as needed. 

15. Left click the Apply button to display the annotation. Below is an example of cross 

sections with Segments annotated. 

 

16. Close the Cross Sections dialog box and review the annotated sections. 
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Displaying Features in Cross Sections 

Displaying existing surface features, like drainage structures, in the cross sections will help to 

evaluate design needs in areas that impact existing structures. 

 

 

Note:  Example Cross Section 

The procedure for displaying features in cross sections follows. 

17. Verify that the Global Scale Factor is set to the desired scale prior to creating the cross 

sections. 
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18. From the InRoads, menu select Evaluation > Cross Section > Cross Sections. The 

Create Cross Section dialog box will appear. Left click Preferences to load the 

appropriate saved preferences. In this example the CDOT preferences will be used. 

 

19. On the Include leaf in the Cross Sections dialog box, verify that Crossing Features and 

Projected Features are checked off. 

20. Left click Apply. The dialog box will minimize allowing the selection of the origin for the 

cross section set with a Left click in a MicroStation View. 
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Display True Scale Cells 

1. Left click the Update Cross Section folder in the dialog box explorer. 

 

The first set of features to display will be the features that are defined to be true scale. These 

features have a defined size, such as pipes. In order to display these types of features properly, set 

the scale factor and feature filter prior to displaying. 

2. Change the InRoads Scale Factor to 1. 

 

Note:  Scale Factor should be 1:1 for true scale cells so that cells come in at actual scale. 

3. From the Locks toolbar Select the CELL_True-Scale filter from the drop-down list 

and toggle on the Feature Filter lock button. 

 

4. Verify the correct Cross Section Set selected. 

5. Left click the Crossing Features Leaf. 

6. Toggle on the Display On radio button.  
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7. From the Surface list box, select the surface name or names to display. The Feature 

list box will then populate with the list of features found in the highlighted surface(s). 

Use the Ctrl or Shift keys to select multiple names. Also, by right clicking in the 

Feature list displays a menu that can be used to select all of the features. 

 

Note:  The feature names in bold are Feature Styles that can be displayed in cross sections. 

Any names that are dithered are not configured to be displayed in a cross section view. 

Note:  If no features are shown in the feature list box, there are no features that meet the 

criteria for the filter selected in step 5. It may be necessary to associate the correct 

feature styles to the desired features if this is the case. Feature styles can be re-

associated by using the Surface > Feature > Feature Properties command. See CDOT 

Update InRoads Features.pdf for more information on the process involved. 

8. Right click in the Feature list and then left click Select All from the menu. The 

Features that can be displayed in cross section view will be highlighted. 
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9. Left click Apply. The dialog will minimize as the features are generated in the cross 

sections. When the process is finished, the dialog will reappear. 

 

Displaying Plot Scale Cells 

The second set of features to display is those that have location only defined with annotation. In 

order to display these types of features, the scale factor and the desired feature filter must be set 

prior to displaying. 

1. Change the InRoads Scale Factor to 20. 

 

Note:  This is the desired plot scale for the set of Cross Sections we are working with. The 

scale should be changed accordingly to match the scale of the original cross sections. 

2. From the Locks toolbar select the CELL_Plot-Scale filter from the pull down list. 

Verify that the feature filter is toggled on. 

  

3. Verify that the correct Cross Section Set is selected. 

4. Left click the Crossing Features Leaf. 
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5. From the Surface list box, select the surface name or names to display. Once a 

surface or surfaces are selected, the Feature list box will populate with the list of 

features. Use the Ctrl and Shift keys to select multiple feature names. Also, by right 

clicking in the Feature list displays a menu that can be used to select all of the 

features. 

 

Note:  The names in bold are Feature Styles that can be displayed in cross sections. Any 

names that are dithered are not configured to be displayed in a cross section view. 

6. Left click Apply. The Update Cross Section dialog box will minimize as the features 

are generated in the cross sections. When the process is finished, the dialog will 

reappear. 
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2. Setting Design Parameters and Reviewing Design 
Data 

This includes various settings that control where design data is generated and how data is 

displayed in MicroStation.  Each task in creating design data should be reviewed as it is completed 

so that the next task will start with the most accurate data possible. 

a. Geometry Review 
i. Reviewing Horizontal Geometry – In creating a design model multiple horizontal alignments 

can be used. These alignments should be reviewed individually and as they relate to each other 

to ensure that they meet the designer’s intent. 

The first review of horizontal geometry should be visual. Start with the project mainline 

alignment. Display the alignment and its stationing into the JPC#DES_Model.dgn file then 

reference in the JPC#SURV_Topo_Scale##.dgn file. This allows the designer to see the topo in 

relation to the design corridor. Verify that the alignment is completely within the surveyed area. If 

the alignment is partially outside the surveyed area additional survey will be required. If it is 

wholly outside the survey area then it must be determined why the two datasets do not match up.   

Review the other alignments associated with the project in the same manner. The illustration 

below shows the main alignment in light red, a secondary alignment in dark red, and a diverging 

alignment in blue. 

 

After these have been reviewed against the topo they should be review against the main 

alignment and each other. In addition to a visual review, InRoads has reports that could be 
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helpful. For example, the Station Base report shows offset distances from the main alignment to 

other alignments at a specified interval. To create a Station Base report: 

 

1. Select Tools > XML Reports > Station Base from the InRoads menu bar. 

 

2. On the General leaf of the Station Base Report dialog box, select the desired Horizontal 

Alignment.  In this example SH 86 is used. 
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3. Select the Include leaf. 

4. In the Horizontal Points area, toggle on On-Alignment. 

5. Toggle on Interval. 

6. Key in the desired Interval value. 

 

 

7. Select the Horizontal Alignments leaf. 

8. In the Include field, key in the desired alignment name (Off Ramp in this example) and 

press the Tab key. 

9. Left click the Apply button. This displays the Bentley InRoads Report Browser. 

 

  



CDOT CADD Manager’s Office 
 

24 

CAD Data checking for Quality Assurance Guide 

10. In the Bentley InRoads Report Browser, select the StationBaseSingle.xsl from the  

StationOffset folder in the left pane. 

 

1. Review the report in the left pane. 

 

Note: There are other Station Base style sheets that may be helpful, like 
StationBaseCoordinates.xsl and StationBaseVerticalClearance.xsl. 
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ii. Enter Event Points for areas of special concern - Event points are those locations 

along the design path (horizontal alignment) that require additional attention during the 

design process. These include drainage structure crossings, driveways and entrances, 

intersections, etc. Once the horizontal alignment has been laid out, the process of 

identifying and storing Event Point can begin. 

 

2. Zoom in to the beginning of the alignment close enough so that items of interest can 

be easily identified. In the example below, three items are identified; the intersection, a 

parking area entrance, and a culvert crossing. 

 

3. To create an Event Point for the culvert, from the InRoads main menu select 

Geometry > Horizontal Curve Set > Events. This displays the Horizontal Events 

dialog box. 
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4. In the Horizontal Events dialog box, set Define By to Single Station. 

5. Click the target button  to activate the command. 

 

6. Select the Intersection snap mode from the Snap Mode tool bar (Note: This toolbar 

may be docked). 

 

7. Tentative snap to the intersection of the culvert crossing and the horizontal alignment. 

Left click to accept the location. 
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8. The station value is entered into the dialog box. A Name for the event point can be 

entered if desired. This will help identifying what each event point represents. In the 

Seed Name field, key in the desired name. 

9. Click the Apply button to complete the command. The event point is added to the list 

at the bottom of the dialog box. 

 

 

The same method can be used for any item that crosses the alignment, like an intersection.  

To add an Event Point for an item that does not cross the alignment: 

10. Repeat steps 1 through 5 above as needed. 
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11. Position the cursor in the center of the item and left click. If the item is a point feature 

or has a line equal to the width of the item, tentative snap to the center of the element 

then left click. The illustration below shows the cursor positioned in the center of the 

parking entrance. 

 

 

12. Adjustments to the Station value can be made within the Horizontal Events dialog 

box prior to clicking the Apply button. In the Seed Name field, key in the desired 

name. 

13. Click the Apply button to complete the command. The illustration below shows the 

dialog box entries for the parking entrance event point. 
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iii. Reviewing Vertical Geometry – Mainline vertical geometry is a major determining factor 

in the amount of earthwork required for a project.  

1. Profile Exaggeration – Choosing the appropriate exaggeration can make laying out 

and reviewing a vertical alignment much easier. As a general rule, one should use a 

larger exaggeration factor on projects with flatter terrain. The illustration below shows 

two profiles of the same area. The bottom profile was created with an exaggeration of 

1 and the top profile with an exaggeration of 5. The higher exaggeration of the top 

profile makes grade changes much easier to see. 

 

 

 

 

When drawing or measuring in a profile using MicroStation commands, the vertical 

exaggeration is not accounted for. The exception is when drawing using the Station / 

Elevation or Distance / Grade precision key ins. Using the InRoads Vertical 

Alignment Tracking does account for the vertical exaggeration. 

2. Annotating Profiles – The first step in annotating a profile is to display the vertical 

alignment annotation. To view the vertical alignment annotation: 

1. From the InRoads menu bar, select Geometry >View Geometry > Vertical 

Annotation. This displays the Vertical Annotation dialog box. 

2. Verify the appropriate Horizontal, and Vertical Alignments are identified in 

addition to the Profile Set. 

3. Select Preferences, Load the desired preference then Close the Preferences 

box. 

 

  

5 times vertical exaggeration 

1 times vertical exaggeration 
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4. Left click the Apply button to display the vertical alignment and its annotation. 

 

The illustration below shows an example of vertical alignment annotation. 

 

Additional annotation is displayed using the Annotate Profile command: 
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5. From the InRoads menu bar, select Evaluation > Profile > Annotate Profile. This 

displays the Annotate Profile dialog box. 

 

6. In the Annotate Profile dialog box, select the Selection leaf. 

7. In the Available column, select the desired items to annotate. Cut Depth and Fill 

Height are selected in this example. 

8. Left click the Add button. This moves the highlighted items from the Available 

column to the Selected column. 

 

In this example, the two added items moved into slots 2 and 3, while Proposed was 

moved to slot 4. In order for all items to display properly, Existing must be 1 and 

Proposed must be 2. To move Proposed back to slot 2: 

9. Highlight Proposed in the Selected column. 
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10. Left click the Move Up button until Proposed is back at the 2 slot. 

 

11. Left click the Apply button to initiate the command. The selected annotation is 

displayed in or near the profile. The illustration below shows examples od existing 

and proposed elevations, cut depth, and fill height. 
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b. Roadway Designer Set up and Review  

Using the proper settings in Roadway Designer will allow the user to create an accurate model by 

delivering appropriate feedback and creating design data at the required locations. 

i. Setting up and reading Roadway Designer displays – Roadway Designer can be set 

to automatically process additional template drops at critical stations. These include 

Event Points defined in the corridor alignment, P.C.s and P.T.s, Superelevation transition 

stations, Point Control stations, etc.  

There are also various display options available. Some items, like the plan display are 

controlled by the software. Other items that are displayed in the cross section view can 

be toggled on as needed. 

To understand the plan view display, examine the illustration below: 
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The template to template transition symbology changes based on the amount of editing 

done on the transition. The illustration below shows the three states of a template to 

template transition. The left image show the initial state when no editing has been done. 

The center image shows that some but not all editing has been done. The right image 

shows the transition with all points connected.  

 

 

 

The basic cross section display shows the existing ground and the template with its 

components. The following additional information can be added to the various Roadway 

Designer displays: 

 Reference Graphics – User specified alignments or surface features that are 

displayed in the plan and cross section views to show the relationship of the 

selected item to the design model. These are shown as solid magenta lines in the 

plan view and dashed magenta lines or bold “+” signs in the cross section view. 

 Transition Graphics – Plan view graphics that show where template to template 

transitions occur and their editing status. These are displayed as described 

above. 

 Triangulated Surface – Plan view graphics that show the top of the triangulated 

design surface. It is displayed as a bold dashed line in the color of the corridor’s 

surface symbology. 

 Cut and Fill Graphics – These are colored shapes that show where existing 

surface material is removed (cut=green) and where additional material is brought 

in (fill=red). Additionally, a bold blue line shows where on the template fill is 

calculated to. 

 Cut and Fill Values – This cross section display shows the Cut Area and the Fill 

Area of the current template drop. Because it does not look back at the previous 

template drop, the volumes remain at 0.00. 

 Net Volume – This cross section display shows the Mass Ordinate for all of the 

processed template drops up to the current location. 

 Null Points – This cross section display shows the location of Null Points within 

the template. They are displayed as bold “+” signs in the color relating to the 

number of constraints applied to the point. 

 Curve Set ID – These are displayed in the Plan and Profile views. They are 

displayed as numbers relating to their location within the horizontal (plan view) or 

vertical (profile view) alignments of the active corridor. 

Unedited                           Partially Edited Fully Edited  
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 Cardinal Points – These are displayed in the Plan and Profile views. They 

represent PCs, Pts, PVCs, and PVTs of the active corridor’s horizontal and 

vertical alignments.They are displayed as normal white “+” signs.  

 Cross Section Tracking – This cross section display is attached to the cursor 

while it is in the cross section view. It shows the offset distance from the corridor 

alignment and the elevation of the cursor’s location. If the cursor is within the limits 

of the design model, it also shows the slope value of the design surface directly 

above or below the cursor. 

To select the desired options: 

7. From the Roadway Designer menu bar, select Tools > Options. This displays 

the Options dialog box. 

 

8. In the Options dialog box Display area, toggle on the desired options. 

9. Left click the OK button. 
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Turn on only the items to be reviewed at that time. Having too many things on at once 

can obscure the cross section and make things difficult to read.  

Other display options have to do the exaggeration of the cross section view. These are: 

 Fit Solution – This option adjusts the horizontal and vertical exaggeration so that 

the entire design model fits into the cross section view. 

 Center Backbone – The user specifies the amount of the template backbone that 

will be displayed in the cross section view and sets a value for the vertical 

exaggeration 

 Center on Current Offsets – The software computes the backbone that will be 

displayed in the cross section view and vertical exaggeration based on the current 

zoom factors. Anytime the zoom is adjusted the new zoom value is used when the 

station is advanced. 

To access the cross section display settings: 

1. Right click in the cross section view port. 

2. Select Display Properties. This displays the Cross Section View Properties 

dialog box. 

 

3. Toggle on the desired View Mode. 

 

4. If either of the Center options are selected, the Backbone Screen Width and 

Vertical Exaggeration can be set. 

5. Left click the OK button. This applies the settings and dismisses the dialog 

box. 
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Fit Solution is the View Mode most commonly used. It ensures that the entire template is 

always visible. Because of their static exaggeration settings, the Center options are best 

for verifying template cross slopes and checking for changes in backbone width in 

transition areas. 

 

ii. Template Drop Interval – The template drop interval determines how often design data 

is processed along the corridor. The recommended maximum template drop interval is 

10’. In areas of complex modeling (intersections, for example) a 1’ interval is specified. 

These intervals were selected to provide a balance between accuracy and intricacy of the 

model with the ability to provide a clean and useable model suitable for use with 

Automated machine Control. 

 

iii. Changing Templates – There are two options to choose from when changing templates 

along a corridor, to transition or not to transition. The transition option should be used 

when the two templates have the same basic structure and only the width is different. Do 

not transition between templates when the pavement structure is different (curb and 

gutter to open section or asphalt to concrete, etc.).  

 

When using the transition option, the transition occurs over the distance from the last 

template drop of the first template to the first template drop of the next template. In the 

illustration below, the left image shows two template drops. Based on the stations of 

those template drops, the transition occurs over 869.72 feet. In the right image a second 

template drop has been added that uses the first template. This reduces the transition 

length to 250 feet. 

 



CDOT CADD Manager’s Office 
 

38 

CAD Data checking for Quality Assurance Guide 

 

iv. Using Event Points and other important stations – Additional template drops should 

occur at event points (defined in the geometry project), geometry cardinal points, 

superelevation transitions, and external control locations.  

1. From the Roadway Designer menu bar, select Tools > Options. This displays 

the Options dialog box. 

 

2. In the Options dialog box Include Critical Sections area, toggle on the 

desired options. 

3. Left click the OK button. The illustration below show the typical settings for the 

Include Critical Sections area. 
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Point controls, parametric constraints, and Superelevation transition stations are External 

Control Points. 

v. Review Component Quantities - The Component Properties command gives a volume 

total of the surfacing components and the area of linear components. Components that 

use the same feature style a lumped together into a single quantity. To generate 

Component Properties: 

1. Left click the  to advance the Station indicator to the end of the 

corridor. 

 

2. Left click the Process All button. If either step 1 or 2 are omitted, the 

quantity will not be correct for the corridor as a whole. 

 

3. From the Roadway Designer menu bar, select Tools > Component 

Properties. This displays the Component Properties dialog box.  
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Note: that volumes are given in cubic feet and area is given in square 

feet. 

 

An estimated material cost can be generated entering a dollar amount in the unit cost field. 

Remember, unit costs may need to be converted to the appropriate unit (cubic feet for 

volumes and square feet for area). 

4. Key in the desired value in the Unit Cost field and press the Tab key at 

accept. The total estimated cost for the item and the grand total are 

automatically calculated.  

 

An XML report of the estimated quantities can be created. The reports converts cubic feet to 

cubic yards but it leaves the area measurements in square feet. 

3. Left click the Report button. This displays the Bentley Civil Report Browser 

with the estimate data. 

 



CDOT CADD Manager’s Office 
 

41 

CAD Data checking for Quality Assurance Guide 

Below is an example of the report.  
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3. Creating and Reviewing the Design Surface Model  

The design model should be reviewed in a similar manner as the existing surface. The main 

difference in the models is that the design model has 3 dimensional components that define the 

pavement structure which is not present in the existing ground model. 

a. Set up the Create Surface command 

The last step in Roadway Designer is creating the design model. Understanding the options 

available in the Create Surfaces dialog box is key to getting an accurate design model. Design 

models created from a single corridor are straight forward. Creating a design model from 

multiple corridors can be a little more complex. 

General Options – These are items that can be applied to any design model. Below is a brief 

explanation of each option. 

 New Surface for Each Corridor – When on, all surfaces created are named using the 

corridor’s name. The Name field is greyed out so that nothing can be entered in it. If 

multiple corridors are selected a design model for each corridor is created using only the 

data defined in that corridor. 

When off, only one corridor is created. The user must enter a name in the Name field for 

the design model. If multiple corridors are selected the design model contains data from 

all corridors selected. 

 Empty Design Surface – When on, if the design model being created uses the exact 

name of a surface currently loaded, the data in the loaded surface is deleted before the 

corridor(s) is processed.  When off, the corridor data is added to the existing dtm. 

 Include Null Points – When on, any Null Points defined in the template are added to 

the design model as untriangulated breaklines. Null Points are generally used as 

measuring devices for point controls and various point constraints and including them in 

the design model resulting in clutter. 

 Triangulate – When on, the triangle mesh for the design model is computed and stored 

with the surface. When off the triangle mesh is not created. The triangles will have to be 

created before any view surface commands can be used. 

 Create Alternate Surfaces – Alternate surfaces are created from points identified in the 

template. Any points within the template can be identified including points that are not 

normally triangulated. So, an alternate surface can be created to represent the top of 

grading for example. When on, the alternate surface(s) is created.  

 Process Visible Range Only – When on, the corridor(s) is only processed to the 

extents that are visible in the plan view of Roadway Designer. When off, the entire 

corridor(s) is processed. 
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 Remove Loops – Loops in a surface are created when template drops overlap. This can 

occur on the inside of arcs with a small radius. This can cause problems with the 

triangulation of the design model. The illustration below shows a corridor with Remove 

Loops toggled off (left) and with Remove Loops toggled on (right). 

 

Features – The Create Surface command make liner breakline features out of every point 

(except null points) defined in the template. The Features area allow two other feature 

types to be added to the design model. 

 Add Transverse Features – A transverse feature represents the design surface that 

is displayed in cross sections. When on, a transverse feature is created at each 

template drop. In most situations, transverse features are redundant and should not 

be used. However, in areas where side slope vary greatly and in intersections 

transverse features are very useful.  

The DTM_Transverse Style is used when using this option. Transverse features are 

named after the template drop station where they occur. 
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 Add Exterior Boundary – An exterior boundary is used to contain triangles within the 

actual construction area. The boundary feature is given the name Exterior Boundary 

automatically. The Style used for the exterior boundary is DTM_Exterior. The illustration 

below shows the results of a design model using an exterior boundary (left) and the 

same model without the boundary (right). The extra triangles in the right image do not 

represent design data and will cause errors in volume calculations. Therefore, and 

exterior should always be used unless there is a specific reason not to use it. 

 

 

 Duplicate Names – When Empty Design Surface is toggled off additional data can be 

added to a model that already contains information.  These options determine what 

happens to features/components with identical names are stored into the same model. 

o Append – The new data is added to the existing data creating a single 

feature/component. This may result in data being duplicated within the same area. 

o Replace – The existing feature/component is deleted and the new one is added to 

the model. This could result in the unwanted loss of data. 

o Rename - The new feature/component is renamed (usually by adding a “1” to the 

end of the name) and added to the model. This could result in two features with 

duplicate data. 

o Modify – This option modifies the existing feature/component by the new 

feature/component where the two are different. If the modifications to the corridor 

result in templates 

 Densify using Cord Height Tolerance – When placing templates around a horizontal 

curve, points to the outside of the curve will be further apart than what is specified in the 

template drop interval. Vertical curves create a similar distortion, but for the full width of 

the template. This option is used to create additional data in areas of horizontal and/or 

vertical curves to reduce this distortion. Toggle on one or both options as desired.  
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 Display in Plan View – When the Create Surface command processing is complete 

the selected items are displayed in MicroStation. The items are displayed in 3D so 

that they are spatially correct.  

o Features – As the corridor is processed, template points with the same name 

are connected between each template drop. This creates the breakline features 

that define the model. When toggled on, these linear elements are displayed. 

This setting honors the Feature Filter setting, so if the Feature Filter Lock is on 

only features that pass through the filter will be displayed. 

o Components – As the corridor is processed, the features are connected 

together to form the components as defined in the template. This produces 3D 

solids of the surfacing material. When toggled on, these solids are displayed in 

MicroStation. 

 Create Surface(s) from – This area is used to select the corridors that will be used 

to create design models. Corridors can be selected and processed one at at time or 

as a group. If multiple corridors are selected, the output is determined by the setting 

for New Surface for Each Corridor. If on, a new dtm is created for each corridor. If 

off, data from all of the selected corridors is stored in a single dtm. 

To select a single corridor left click on the desired corridor name. To select multiple 

corridors hold the Ctrl key and left click on the desired corridor names A group of 

consecutive corridors can be selected by left clicking on the first corridor, then 

holding the Shift key and left clicking on the last corridor. The All and None buttons 

can be used to select or deselect all of the corridors. 

o Corridor Clipping - Clipping is the removal of overlapping components from a 

design model created from two or more corridors. In situations where two 

corridors are combined into a single model, One corridor, the clipping corridor, is 

used to determine which components are removed from the clipped corridor. 

 Clipping Corridor – Target Aliasing is used to determine which corridor is 

the Clipping Corridor. A corridor with aliasing that targets another corridor is 

the cutting corridor. The targeted corridor is subject to clipping. 

 Targeted Corridor – A corridor that has been selected as a target for 

another corridor is subject to clipping. Where components overlap between 

the Clipping and the Targeted corridors, the targeted corridor’s components 

can be deleted based on the Clipping Option selected. 

o Clipping Options – These specify what components can be removed from the 

targeted corridor. The available options are: 

 Clip None – All components from the targeted corridor are added to the 

design model. 

 Clip End conditions Only – End condition components that are partially of 

fully covered by the clipping corridor are removed from the model. All 

backbone components of the target corridor are added to the design model. 

 Clip All – All components that are partially of fully covered by the clipping 

corridor are removed from the model. 
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The example above shows the same template drop showing all three clipping options. 

The top illustration shows the results of the Clip None option. Notice that the design 

ground line is attached to the end condition of the targeted corridor. When Target 

Aliasing is used the targeted corridor must be processed first in order for the Clipping 

Corridor to have something to hit. Because the end condition and the Z Slope 

components of the targeted corridor were initially triangulated, they retain that setting in 

the combined surface resulting in the design surface following those features. 

The middle illustration shows the Clip End Conditions Only option. Notice that the end 

condition component of the Targeted Corridor is gone. The Z Slope is a backbone 

component so it is retained and used to create the triangulated surface. 
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The bottom illustration shows the Clip All option. Because the end condition and the Z 

Slope components are both removed, the design surface extends from the end of the 

Clipping Corridor, the Median Ditch Bottom, then to the left edge of pavement of the 

target corridor. 

Any features that are overlapped by the Clipping Corridor will be deleted based on the 

Clipping Option selected. Features of deleted components that are not overlapped are 

retained in the design surface and may be used for triangulation of the combined 

surface. The illustration below shows a cross section of a combined corridor surface 

where the Clipping Corridor overlaps into the Targeted Corridor’s surfacing components. 

Even though the surfacing components have been deleted, the features have not. 

 

To prevent the unwanted deletion of surfacing components, additional templates with 

vertical edges where the corridors merge. Also, point controls should be defined so that 

the corridors meet but do not cross each other.  
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Creating The Design Surface - To create the design surface: 

1. Select Create Surfaces from the Corridor dropdown menu or from the button bar . 

This displays the Create Surfaces dialog box. 

2. Key in the desired surface Name, if needed. 

3. Select the corridors from the Create Surface(s) from area and set the Clipping 

Options. 

4. Make the desired General Option, Features, Densify, and Display settings. 

5. Left click the Apply button. This executes the command and creates the design 

model(s). 

 

b. Review design surface Properties 

This is done in the same manner as 1.a above.   

1. Right click on the surface name in the InRoads Explorer and select Properties from the list. 

2. In the Surface Properties dialog box, review the Data Range area. Look for entries that 

seem abnormal for the area of the project. The most common and easily recognizable issue 

is a zero minimum elevation. There should be no zero elevations in the design surface. 
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3. Left click on the Advanced tab. The Cross Sections and Profiles Symbology should be 

set to D_Finished-Grade or D_Surface.# (the # represents the numbers 1 through 10). The 

D_Finished-Grade is used to represent the mainline surface. The D_Surface_# symbologies 

are used for all other design surfaces. Use the drop down menus to select the appropriate 

symbology for the surface. Use the same style for both Cross Section and Profile 

symbology. 

 

4. Left click the Apply button to accept the changes. Left click Close to dismiss the dialog box. 

c. Review design surface Contours 

To display contours of the design model surface: 

1. From the InRoads menu bar, select Surface > View Surface > Contours. This displays the 

View Contours dialog box. 
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2. In the View Contours dialog box, left click the Preferences button. This displays the 

Preferences dialog box. Preferences are used to determine how the contours are displayed 

in MicroStation. There are several Proposed preferences that are available. These are used 

for displaying contours of design surfaces so that they can be distinguished from existing 

ground contours. 

3. Highlight the desired preference from the list then left click the Load button followed by the 

Close button. 

 

The same logic applies to design model cross sections as it does to existing ground cross 

sections. Use an interval that provides enough information without obscuring other important 

information. The illustration below shows an example of design model contours as the roadway 

transitions from the standard template on the left to a superelevated template on the right. 
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d. Review design surface Topo 

Most anomalies in the design model should have been taken care of before the surface was 

created. However, some of these anomalies may not be clearly identifiable within Roadway 

Designer. Reviewing the triangulated features of the design surface provides another chance to 

locate these anomalies. To view the triangulated design features: 

1. From the InRoads Locks toolbar, select the feature filter XS Excluded from Triangulation. 

This filter only allows triangulated features to be displayed. 

2. Toggle on the Feature Filter Lock. This activates the filter so that it is used. 

 

3. From the InRoads main menu, select Surface > View Surface > Features. This displays 

the View Features dialog box. 
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4. In the View Features dialog box, verify that the Surface is set to the design model. 

5. By default, all of the features are selected. Left click the Apply button to activate the 

command. 

 

6. Left click the Close button to dismiss the View Features dialog box. 

The illustration below shows an example of an anomaly in the design model. In this case, a 

single toe of slope extends far past the surrounding data. Viewing the design model feature 

data in conjunction with the survey TOPO can help to determine if the anomaly is caused by 

an existing terrain element (like a creek channel) or if its and issue with either the corridor 

path (horizontal and/or vertical alignment) or the template design. 
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If the problem is with a design element (template or alignment, for example) fix the element, update 

the corridor with the fixes, and re-create the design model. If the issue is legitimate, then some 

modifications to the corridor can eliminate or reduce the severity of the anomaly. Depending on the 

problem, some options include End Condition Overrides, Point Controls, and Single Station Edits.  

4. Comparing Existing Surface and Design Models 
Data 

The final steps to complete the QA process are to compare the design model to the existing ground. 

This helps to determine the feasibility of the design and can be used to maximize efficiency. In 

order to ensure consistency between electronic data and plan set data, End Area Volumes 

(included in the plan set) need to be compared to Triangle Volumes (electronic data). Because 

Triangle Volumes only use the triangulated surface data from the existing and design models, the 

cross sections used to compute end area volumes must also only contain triangulated data. That 

means the Component display must be turned off. Once it has been verified that the end area 

volumes are within the tolerances when compared to the triangle volumes, surfacing and other data 

can be added to the cross sections and final end area volumes can be calculated. 

a. Cross Section set-up 

Cross sections have been one of the standard tools for evaluating designs for decades. The 

advantage of using cross sections for earthwork quantities is that the quantities are checkable 

by hand. The disadvantage of using cross sections for earthwork quantities is that not all of the 

data is used to compute the volumes. 

In order to maximize the data used and the accuracy of the computations, cross sections should 

be generated in the same locations as the template drops in Roadway Designer.  

To set up cross sections to match Roadway Designer template drops: 

6. Select Evaluation > Cross Section > Cross Sections from the InRoads bar menu. 

This displays the Cross Sections dialog box. 

7. From the Cross Sections dialog box, left click the Preferences button. This displays 

the Preferences dialog box that is associated with Cross Sections. 

8. From the Preferences dialog box, highlight the desired preference and left click 

Load. 
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9. Left click Close to dismiss the Preferences dialog box. 

 

10. Change the Interval to match that used in the corridor that is being cross sectioned. 

11. Set the Left Offset and Right Offset values to ensure that the entire width of the 

design surface is visible within the cross section window. 

12. Select the Source leaf and verify that the correct alignment is selected. 
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13. Select the Include leaf. Toggle off Components. This ensures that the data used for 

end area volumes is the same as that used for triangle volumes. 

 

14. Expand the Controls folder. Set the Limits as needed. 
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15. Select the Critical Sections leaf. Toggle on the same items that were used in 

Roadway Designer. 

 

Note: Typically Event Points are assigned to the horizontal geometry. If event points 

have been assigned to the vertical geometry toggle them on as well. Also, 

Superelevation Event Stations are legacy data from when superelevation was 

stored as part of the horizontal geometry so toggling it on will have no effect on the 

cross sections. Superelevation stations in the current version are External Control 

Points and can be included in the cross section set by toggling that option on. 

16. Left click the Apply button then left click the location for the cross sections. This 

creates a cross section set. Below is an example of what a cross section will look like. 

Notice that there are no surfacing components displayed. 

 

If multiple template drop intervals were used in the corridor, these can be matched using a custom 

cross section definition. Only cross sections that are perpendicular to the source alignment are 

used to calculate volumes. When creating a custom cross section set for volumes, use only the 

Station Range and Perpendicular options. To create a custom cross section definition: 

1. Expand the Custom folder, this displays the custom cross section leaf. 

2. Set the Type to Station Range. 

3. Set the Start Station to that of the first template drop. 
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4. Set the Stop Station to that of the next template drop. 

5. Set the Interval to that used for the first template drop. 

6. Set the Left Offset and Right Offset to a value that allows the entire design surface 

width to be displayed. 

7. Left click the Add button. This creates the entry for that station range. 

8. Set the Start Station to one interval past the beginning of the second template drop. 

In the example below, the second template drop is at 231+75.30 and the interval for 

the second template drop is 5 feet. The Start Station is rounded to the nearest 5 foot 

past the template drop entry, so 231+80.00 is entered. 

9. Repeat steps 4 through 9 until all of the template drops are used. Note, the Stop 

Station for the last station range is that for the end of the project. 

The illustration below shows the Template Drops dialog box from Roadway Designer (left) 

along with the custom cross sections leaf (right). The arrows point from the template drops 

to the corresponding cross section station ranges. 

 

Custom cross section sets honor Critical Stations listed under the Controls leaf, so all of the 

cardinal points, event points, and external control points will be included in the set without having to 

enter them separately. 

10. Once all the custom entries are made, left click the Apply button to create the cross 

sections. 

b. End Area Volume set-up 

When generating end area volumes to compare to the triangle volumes, only the basic settings that 

are found on the General leaf will be used. To compute end area volumes: 

1. Select Evaluation > Cross Section > Cross Sections from the InRoads bar menu. 

This displays the Cross Sections dialog box. 
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2. Verify that the desired Cross Section Set is selected. If one was created, this should 

be the custom cross section set that matches the template drops in Roadway 

Designer. 

3. From the Cross Sections dialog box, expand the End-Area Volumes folder. This 

displays the end area volumes General leaf. 

4. Verify that the correct existing surface and the correct design surface are selected. 

5. In the Imperial Units area, toggle on Cubic Yards. 

6. Toggle on Create XML Report. This report contains the data that will be compared to 

the triangle volumes. 

7. Left click the Apply button to execute the command. 

 

The Bentley Civil Report Browser is displayed containing the End Area Volume 
Report. 
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8. Scroll to the bottom of the report. The illustration below identifies the columns of 

interest. 

 

For the cut and fill totals, the left entry is the normal quantity and the right entry is the 

adjusted quantity. Because no adjustments were made the values are the same. 

9. In the Bentley Civil Report Browser, select File > Save As from the menu bar. This 

displays the Save As dialog box. 

10. In the Save As dialog box, navigate to the appropriate project folder. 

11. Set the Save as type to DOC File (*.doc). 

12. Key in the desired File name. 

13. Left click the Save button to create the report file and dismiss the Save As dialog box. 

 

14. Close the Bentley Civil Report Browser. 

The end area volume report file will be referred to when comparing the end area volumes to 

the triangle volumes. 
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c. Generating Triangle Volumes 

Triangle volumes are the most accurate measurement available. This is because the command 

compares the whole existing surface to the whole design surface with no interpolation and minimum 

rounding in the calculations. The disadvantages to triangle volumes are: 

 There is no way to manually check the quantity 

 They do not account for surfacing material 

However, if the end area volumes calculated above and the triangle volumes are within the 

tolerances, then we can be confident that the end area volumes accounting for surfacing material 

will be accurate. To compute Triangle Volumes: 

1. From the InRoads main menu, select Evaluation > Volumes > Triangle Volume. 

This displays the Triangle Volume dialog box. 

 

2. In the Triangle Volume dialog box, set the Mode to Entire Surface. 

3. Set the Original Surface to the existing ground surface for the project. 

4. Set the Design Surface to the design model that is being evaluated. 

5. Verify that the Cut Factor and Fill Factor are set to 1.00. 

6. Left click the Add button. This puts the data into the “to be processed” list.  

7. Left click the Apply button. This computes the volumes and displays the results in the 

Bentley Civil Report Browser  
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The illustration below is an example of the Triangle Volume report. 
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d. Comparing Triangle Volumes to End Area Volumes 

To compare the two volume totals, simply open both reports and compare the like categories. The 

illustration show which items to compare. 

 

The chart below shows the comparison of the end area and triangle volumes from the illustration 

above. 

 End area 

Volume 

Triangle 

Volume 

Difference in 

Cubic Yards 

Percent 

Difference 

Cut 4829.0 4824.9 4.1 0.08% 

Fill 25132.5 25150.6 18.1 0.07% 

Net -20303.6 -20325.7 22.1 0.1% 

If the differences in volumes falls outside the acceptable range, it must be determined where the 

differences occur. Start by reexamining the cross sections. One common error is to use an offset 

that is too narrow for the design data. The illustration below shows two sets of cross sections using 
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the same data. The left cross sections are wide enough to display the entire design model, the right 

cross sections are not. While the differences on a single cross section may not be great, that can 

add up quickly, especially on a long project. 

 

If the cross sections are complete then another cause for the discrepancy must be found. One 

option is to compare the end area volumes with the Triangle Volume By Station report.  The 

Triangle Volume By Station report Breaks down the triangle volumes to user specified intervals. 

This can then be compared to the End Area Volume report to find where the problem is. To create 

a Triangle Volume By Station report: 

1. From the InRoads main menu bar, select Evaluation > Volumes > Triangle Volume by 

Station. This displays the Triangle Volume by Station dialog box. 

 

2. In the Triangle Volume by Station dialog box, on the Main tab, set the Original Surface to 

the existing ground surface. 
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3. Set the Design Surface to the design model in question. 

4. Set the Alignment to the one used to create the cross sections that the End Area Volume 

report was taken form. 

5. Set the Interval to that used to create the cross sections. 

6. Set the Offsets to a value that will ensure that all design data is within the offset limits. 

 

7. Select the Advanced tab. 

8. On the Advanced tab, in the Include area, set the Cardinal and Event points as they were 

when the cross sections were generated. 

If multiple template drop intervals were used in creating the design model, then the Triangle 

Volume by Station command will need to be run for each template drop interval. 

9. If needed, in the Limits area, toggle on Station and key in the Start and Stop stations. If 

station limits are not needed, toggle off Station. 

10. Verify that the Volume Factors are both set to 1.00. 

11. Left click Apply to generate the report. This displays the Bentley Civil Report Browser. 
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12. In the Bentley Civil Report Browser select the BasicVolume.xsl as the style sheet. 

 

The illustration below shows the Triangle Volume by Station report on the left and the End Area 

Volume report on the right. By comparing the indicated columns station by station, the location of 

the discrepancy can be located. 

 

Once the location of the issue has been determined, review the information in the plan view, 

cross sections, Roadway Designer, and in 3D to determine the cause of the problem. 

Should the two volumes be within the tolerances, then a new set of cross sections 

containing the surfacing components can be created for the plan set. 

e. Using Mass-Haul Diagrams  

A mass haul diagram is a graphical representation of the amount of earthwork contained within a 

project. It can also be used to maximize the use of onsite material and reduce trucking costs. 
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vi. Creating A Mass Haul Diagram - A mass-haul diagram looks like a profile but the 

“ground line” represents the amount of earthwork. It is, in fact, using the Mass Ordinate 

for the data line. Set up the End Area Volumes dialog box as desired. To display a Mass 

Haul diagram: 

1. Select End-Area Volumes from the dialog box explorer. 

2. Toggle on Plot Mass Haul Diagram. 

 

3. Select Mass Haul Diagram from the dialog box explorer. 

4. Left click the Preferences button. 

5. Select the desired preference then left click Load and Close. 

 

The mass-haul diagram is generated when the end-area volumes are calculated. 

6. Left click the Apply button. 

7. After the end-area volumes are calculated, you are prompted to identify the location 

for the mass haul diagram. 
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8. Left click to identify the location of the lower left corner of the diagram. Below is an 

example of a mass haul diagram. 

 

vii. Reading and Using a Mass Haul Diagram - A mass haul diagram illustrates the 

accumulated algebraic sum of the cubic yards of earthwork on a project. These diagrams 

are used as an aid in balancing earthwork, computing haul distances, and calculating 

quantities. 

The mass haul diagram is laid out with Stations running horizontally and cubic yards of 

earthwork running vertically. Items of interest in the diagram are: 

 

 Mass Line - This is the data line of the mass haul diagram. It is a graphic 

representation of the Mass Ordinate that is displayed on cross sections and in the 

end area volume report. 

 Excavation - This is shown by a rise in the data line when read going up station. 

 Embankment - This is shown by a drop in the data line when read going up station. 
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 Point of Maximum Earthwork - This is where the volumes change from a net 

excavation to a net embankment. 

 Point of Minimum Earthwork - This is where the volumes change from a net 

embankment to a net excavation. 

 Base Line - This indicates the limits of an area of balanced earthwork (where 

excavation and embankment have equal values). The arrow indicates the direction of 

haul. 

 Borrow (or Waste) - Barrow indicates an area where additional material will have to 

be brought in from off-site. Waste indicates an area where excess material must be 

disposed of. 

It is up to the designer to indicate the Base Lines, Point of Maximum Earthwork, Point 

of Minimum Earthwork, and areas of Borrow or Waste on the mass haul diagram. 

Other items that can be added to the diagram are haul volumes for each base line, 

volumes for areas of borrow and waste, and sheet estimate volumes. 
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